Sandboxing

Expand all | Collapse all

FORTISANDBOX Prefilter command execution Error

Jump to Best Answer
  • 1.  FORTISANDBOX Prefilter command execution Error

    Posted Nov 12, 2019 04:53 AM
    Hi All,
    I have an error when I run the following command on the FortiSandbox 1000D.

    Can someone help me?

    > sandboxing-prefilter -l
    Status for sandboxing prefilter:
    dll: disabled
    pdf: disabled
    swf: disabled
    js: disabled
    htm: disabled
    url: disabled
    office: disabled
    trustvendor: disabled
    trustdomain: enabled
    archive: enabled

    > sandboxing-prefilter -e dll pdf swf js htm url office trustvendor
    ERROR: Incorrect options

    Usage: sandboxing-prefilter [-h | -l | -e | -d] -t [dll | pdf | swf | js | htm | url | office | trustvendor | trustdomain | archive]
    -h Help information.
    -e Enable sandboxing prefilter.
    -t [dll | pdf | swf | js | htm | url | office | trustvendor | trustdomain | archive] Enable sandboxing prefilter for specific file types.
    -d Disable sandboxing prefilter.
    -t [dll | pdf | swf | js | htm | url | office | trustvendor | trustdomain | archive] Disable sandboxing prefilter for specific file types.
    -l Display the status of sandboxing prefilter.

    thank's


  • 2.  RE: FORTISANDBOX Prefilter command execution Error
    Best Answer

     
    Posted Nov 12, 2019 06:55 AM
    You are missing the "-t" flag that specifies the type of filter you want to enable.
    Example of enabling the DLL prefilter:
     sandboxing-prefilter -e -tdll

    Note:  There is no white space between the -t flag and the followed option


  • 3.  RE: FORTISANDBOX Prefilter command execution Error

    Posted Nov 13, 2019 02:49 AM
    Hi Jim,
    Thank you very much.
    Everything work now.