Topic Thread

Expand all | Collapse all

FortiManager security profile error

  • 1.  FortiManager security profile error

    Posted 04-19-2016 17:31

    Hello

    I am new to FortiManager and am trying to set up some security filtering on my network policies. I have configured my polices and pushed everything out to the FortiGates but I am now trying to assign some security profiles to the policies and am getting the following error:

    firewall/policy/1/ : Attribute 'profile-protocol-options' MUST be set.

    It doesn't matter which policy I try and edit, I still get the 'attribute must be set' error. I have tested and can add the security profile to the policy directly on the FortiGate but this obviously needs to be done from the FortiManager.

    Has anyone seen this error?

    Regards,

    Andre



  • 2.  RE: FortiManager security profile error

    Posted 04-19-2016 22:06
      |   view attached

    Hi,

    This is because you need to set the "Proxy Options" in your policy, as shown in attached picture.

    Could you please let us know your FMG version? (get system status)

    Best Regards.



  • 3.  RE: FortiManager security profile error

    Posted 04-20-2016 12:12

    Hi and thanks. It was as simple as that apparently. My googling skills let me down in this case so I appreciate your help. By the way, your question about the FMG version v5.4.0-build1019 160217 (GA) platform 200D.

    Andre



  • 4.  RE: FortiManager security profile error

    Posted 04-24-2016 19:43

    Just for your information, we're going to have this additional settings to be set automatically (with default profile).

    It will be in FMG 5.4.1.

    Thanks having raised this!



  • 5.  RE: FortiManager security profile error

    Posted 07-27-2016 09:22

    I haven't tested this yet in a 5.4.1 deployment. Can you confirm if this change made it into the release?

    -Andrew



  • 6.  RE: FortiManager security profile error

    Posted 08-03-2016 14:38

    Hi Andrew

    I have just tested it now. It looks like if you don't specify a proxy option it automatically chooses the default. No errors anymore.

    Thanks,

    Andre